package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/_?api\/v\d+`)
var str = `'/api/v1' or '/_api/v1'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}