using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/mnt/internal-app/logs/internal-app\.log_2019-08-2[01].*";
string input = @"/mnt/internal-app/logs/internal-app.log_2019-08-20.log.gz
/mnt/internal-app/logs/internal-app.log_2019-08-21.log.gz
..
..
/mnt/internal-app/logs/internal-app.log_2019-08-25.log.gz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}