use strict;
my $str = 'T &CC3:5 Q8 Party/ Self-Identify&CC6:8 Male&CC9:11 Female&CC12:15 Q1 Vote&CC16:22 Q7 Ideology&CC23:31 Party//Ideology&CC32:33 Q9 Trump&CC34:35 Q10 Sanders&CC36:39 Q11 Polis&CC40:43 Q12 Hickenlooper&CC44:47 Q13 Gardner&CC48:50 Q14A Pres.&CC51:53 Q14B Pres.&CC54:56 Q15A Senate&CC57:59 Q15B Senate&CC60:62 Q18 Initial&CC63:66 Q29 After&CC67:69 Q19A Initial Long&CC70:72 Q20A Initial Short&CC73:76 Q28A After&CC77:79 Q19B Initial Long&CC80:82 Q20B Initial Short&CC83:86 Q28B After&CC87:89 Q21/ Banning Oil && Gas&CC90:92 Q22 Argumentation/ Ballot&CC93:95 Q23 2500 Foot/ Setback Measure&CC96:99 Q16 Protect Environment&CC100:102 Q17 Oil && Gas/ Regulation&CC103:104 Q5 Gender&CC105:108 Q6 Race&CC109:112 Q30 Education&CC113:113 White&CC114:116 Q31 Income&CC117:127 Q32 Area Breaks&CC128:134 Q4 Age&CC135:138 Men&CC139:142 Women';
my $regex = qr/(&CC[0-9]+:[0-9]+).*?(?=&C|$)/mp;
my $subst = '$1==';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";