$re = '/test:\s++(?!\[ABCD)/m';
$str = 'test: [ABCD]
test: foobar
test: [ABCD]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);