import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<indentation>(?P<sp_or_tab>[ \\t])*+)(?P<stmt>(?P<non_str_lit>(?:(?!\\#)[^\\\"'\\r\\n])*?)(?:(?P<str_lit>(?P<begin_quote>(?P<single_quote>')|\\\")(?:(?(single_quote)\\\"|')|\\\\[\\\"']|\\\\[^\\r\\n ]|[^\\\"'\\\\\\r\\n])*?(?P=begin_quote))(?&non_str_lit))*?)(?P<whitespace>(?&sp_or_tab)*+)(?P<comment>(?:\\#)[^\\r\\n]*+)?(?P<line_ending>\\r|\\n|\\r\\n)?$";
final String string = "print(\"Hello, world!\") # this is a comment.\n"
+ "print(\"The quick \\\\brown\\\\\\ndog\\rfox\\tjumps\\t over #the# /lazy/ \\\"dog\\\"###\") # and here's where the real comment starts\n"
+ " print(\"you can use Alt+0009 to enter a tab character!\")\n"
+ "# The above line had no comments, so the <comment> group didn't participate in the match.\n"
+ " print(\"indented code\") # with comment\n"
+ " print(\"never indent code like this, but it still matches anyway\")# comment lacking preceding whitespace >:)\n"
+ " print(\"space indented code\")\n"
+ "print(\"Missing end quote\n"
+ "print(\"unescaped \\\")\n"
+ "print(\"implicitly\" \" joined## \" \"string \" \"lit#erals\") # a line can contain multiple string literals\n"
+ "print(\"the quick \" # line 1\n"
+ " \"brown fox \" # line 2\n"
+ " \"jumps over \" # line 3\n"
+ " \"the lazy dog\") # line 4\n\n"
+ " print(\"The quick brown\", animal, \"jumps over the\", adjective, animal2, sep=\" \") \"\n"
+ "print('Robert'); DROP TABLE `Students`; -- ')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}