use strict;
my $str = '听好听的歌
我想听蜻蜓fm郭德纲的相声
我要听蜻蜓fm郭德纲的相声等等等等
蜻蜓的是的是的
听周杰伦的歌
蜻蜓fm于谦的相声
蜻蜓fm的于谦的相声
想听skds的草根创业最好的项目
想听刘德华的歌
我想听于放的相声的地点的电视
想听好听的音乐
想听铁齿铜牙纪晓岚
我想听中国之声
要听圣诞节
听蜻蜓fm
我想听相声
好听的歌
听广播电台
周杰伦的菊花台
听fm
听六千的相
听加快时间打开手机端
听有声书
听音乐
听蜻蜓fm收银员
听歌曲
';
my $regex = qr/.*斗地主/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}