package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?`)
var str = `http
https
ftp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}