#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:EUR|USD|GBP)(\ )(?:(?:(?:\d+(\ ))+\d+)|\d+\.\d+|\d+)+(?:(\ )(?:Mio\.|million|billion))?"
Local $sString = "EUR 1.2" & @CRLF & _
"EUR 1.23" & @CRLF & _
"EUR 12" & @CRLF & _
"EUR 123" & @CRLF & _
"EUR 12 Mio." & @CRLF & _
"EUR 12 345 Mio." & @CRLF & _
"GBP 1 123 456 789 Mio." & @CRLF & _
"USD 12 million" & @CRLF & _
"EUR 1.23 billion"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")