import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<show>[\\w ]+) - (?<episode>S[0-9]{2}E[0-9]{2}E?[0-9]{0,2}) - (?<title>[\\w -]+)(?: - )(?<res>(?:720p)|(?:1080p))";
final String string = "Show Name - S01E02 - This Is a High-Def Episode Title - 720p\n"
+ "Show Name - S01E03 - This Is a High-Def Episode Title - 1080p\n"
+ "Show Name - S01E04 - This Is a Standard-Def Episode Title\n"
+ "Show Name - S01E05E06 - This Is a High-Def Double Episode Title - 720p";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}