import re
regex = re.compile(r"(?<!\d|USD)\d+", flags=re.MULTILINE)
test_str = ("USD 100\n"
"USD100\n"
"USD50\n"
"EUR50\n"
"USD500\n"
"MXN500")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")