#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(\$.*):)"
Local $sString = "$application-background: rgba(81, 99, 120, 0.1);" & @CRLF & _
"$application-background-light: #ffffff;" & @CRLF & _
"" & @CRLF & _
"$primary-light: #00a6ff; // rgba(0, 166, 255, 1)" & @CRLF & _
"$primary-light-accent: #1f95f8;" & @CRLF & _
"$primary-lighter: #99dcff;" & @CRLF & _
"$primary-dark: #36436b; // rgba(54, 67, 107, 1)" & @CRLF & _
"$primary-darker: #2b3555;" & @CRLF & _
"$primary-darkest: #191f32;" & @CRLF & _
"$secondary-light: #008aff;" & @CRLF & _
"$tertiary-light: #4f5bff;" & @CRLF & _
"$quaternary-light: #27358c;" & @CRLF & _
"$sub-accent1: #00ea42;" & @CRLF & _
"$sub-accent2: #bedb00;" & @CRLF & _
"$sub-accent3: #ffb428;" & @CRLF & _
"" & @CRLF & _
"$widget-light: #f3f4f6;" & @CRLF & _
"$widget-lightest: #ffffff;" & @CRLF & _
"$widget-disabled-light: #ccc;" & @CRLF & _
"$widget-disabled-lighter: #f9f9f9;" & @CRLF & _
"$navbar-color-default: $widget-lightest;" & @CRLF & _
"$navbar-light-color: #fafafa;" & @CRLF & _
"$sidebar-background: #fafafa;" & @CRLF & _
"$text-light: #516378;" & @CRLF & _
"$text-lighter: #889aae;" & @CRLF & _
"$text-lightest: #cccccc;" & @CRLF & _
"$text-dark: #ffffff;" & @CRLF & _
"$text-dark2: #efefef;" & @CRLF & _
"$text-darker: #dedede;" & @CRLF & _
"$text-disabled: $text-lightest;" & @CRLF & _
"$text-placeholder-dark: $text-dark2;" & @CRLF & _
"$text-navbar-bright: rgba(0, 0, 0, 0.9);" & @CRLF & _
"$text-navbar-bright2: rgba(0, 0, 0, 0.4);" & @CRLF & _
"$text-navbar-dark: rgba(255, 255, 255, 1);" & @CRLF & _
"$text-navbar-dark2: rgba(255, 255, 255, 0.4);" & @CRLF & _
"$border-light: #e8ebed;" & @CRLF & _
"$border-dark: #ccc;" & @CRLF & _
"$border-active: $text-light;" & @CRLF & _
"$border-color-dark: #d9d9d9 $border-dark #b3b3b3;" & @CRLF & _
"$warning: #ffa908;" & @CRLF & _
"$trend-high: #ff3d79;" & @CRLF & _
"$trend-low: #1e98ff;" & @CRLF & _
"$trend-mid: $text-light;" & @CRLF & _
"" & @CRLF & _
"$list-item-selected: rgba(81, 99, 120, 0.2);" & @CRLF & _
"$list-item-hover: rgba(81, 99, 120, 0.1);" & @CRLF & _
"" & @CRLF & _
"$poor: #ff7da5;" & @CRLF & _
"$fair: #ffafc8;" & @CRLF & _
"$average: #ffdfa4;" & @CRLF & _
"$good: #a1d525;" & @CRLF & _
"$excellent: #00d63d;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":export {" & @CRLF & _
" primaryDark: $primary-dark;" & @CRLF & _
" primaryLight: $primary-light;" & @CRLF & _
" secondaryLight: $secondary-light;" & @CRLF & _
" tertiaryLight: $tertiary-light;" & @CRLF & _
" quaternaryLight: $quaternary-light;" & @CRLF & _
" subAccent1: $sub-accent1;" & @CRLF & _
" subAccent2: $sub-accent2;" & @CRLF & _
" subAccent3: $sub-accent3;" & @CRLF & _
" poor: $poor;" & @CRLF & _
" fair: $fair;" & @CRLF & _
" average: $average;" & @CRLF & _
" good: $good;" & @CRLF & _
" excellent: $excellent;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"$black: black;" & @CRLF & _
"$black-10: rgba(0, 0, 0, .1);" & @CRLF & _
"$black-15: rgba(0, 0, 0, .15);" & @CRLF & _
"$black-20: rgba(0, 0, 0, .2);" & @CRLF & _
"$black-30: rgba(0, 0, 0, .3);" & @CRLF & _
"$black-40: rgba(0, 0, 0, .4);" & @CRLF & _
"$darker: #152128;" & @CRLF & _
"$darker-40: rgba(21, 32, 40, .4); // rgba($darker, .4)" & @CRLF & _
"$darker-50: rgba(21, 32, 40, .5); // rgba($darker, .5)" & @CRLF & _
"$darker-70: rgba(21, 32, 40, .7); // rgba($darker, .7)" & @CRLF & _
"$darker-80: rgba(21, 32, 40, .8); // rgba($darker, .8)" & @CRLF & _
"$darker-90: rgba(21, 32, 40, .9); // rgba($darker, .9)" & @CRLF & _
"$dark-two-10: rgba(81, 99, 120, .1);" & @CRLF & _
"$dark-two-20: rgba(81, 99, 120, .2);" & @CRLF & _
"$dark: #516378;" & @CRLF & _
"$dark-60: rgba(81, 99, 120, .6);" & @CRLF & _
"$dark-10: rgba(81, 99, 120, .1); // rgba(80, 99, 120, .1) rgba(81, 99, 119, .1)" & @CRLF & _
"$dark-15: rgba(81, 99, 120, .15);" & @CRLF & _
"$dark-30: rgba(81, 99, 120, .3);" & @CRLF & _
"$dark-20: rgba(81, 99, 120, .2); // rgba(80, 99, 120, .2) rgba(81, 99, 119, .2)" & @CRLF & _
"$dark-40: rgba(81, 99, 120, .4);" & @CRLF & _
"$dark-6: rgba(81, 99, 120, .06);" & @CRLF & _
"$gray: #7C858C;" & @CRLF & _
"$light: #98A7B3; // #97A7B4 #97A6B2" & @CRLF & _
"$light-50: rgba(152, 166, 179, .5);" & @CRLF & _
"$lighter: #E8EBED;" & @CRLF & _
"$smooth-sky: #87D5FF;" & @CRLF & _
"$sky: #00E2F5;" & @CRLF & _
"$sky-20: rgba(0, 221, 244, .2);" & @CRLF & _
"$magenta: #FF21A3;" & @CRLF & _
"$magenta-10: rgba(255, 33, 163, .1);" & @CRLF & _
"$yellow: #FFB000; // #FFA908" & @CRLF & _
"$lemon: #EDED00;" & @CRLF & _
"$spring: #4BFF6B;" & @CRLF & _
"$green: #00D63D;" & @CRLF & _
"$cobalt: #00A6FF;" & @CRLF & _
"$cobalt-10: rgba(0, 195, 255, .1); // rgba(0, 165, 255, .1)" & @CRLF & _
"$cobalt-20: rgba(0, 195, 255, .2);" & @CRLF & _
"$blue: #4A4FEB;" & @CRLF & _
"$purple: #9270FF;" & @CRLF & _
"$navy: #1B1464;" & @CRLF & _
"$snow: #F3F4F5; // #F2F2F2" & @CRLF & _
"$snow-68: rgba(243, 244, 245, .68);" & @CRLF & _
"$pale-grey-five: #F5F5F7;" & @CRLF & _
"$snow-60: rgba(243, 244, 245, .6); // rgba(243, 243, 244, .6)" & @CRLF & _
"$warm-grey-10: rgba(119, 119, 119, .1);" & @CRLF & _
"$white: white;" & @CRLF & _
"$white-30: rgba(255, 255, 255, .3);" & @CRLF & _
"$white-50: rgba(255, 255, 255, .5);" & @CRLF & _
"$white-70: rgba(255, 255, 255, .7);" & @CRLF & _
"$midnight: #36436B;" & @CRLF & _
"$midnight-hover: #2B3457;" & @CRLF & _
"$dawn: #5B83FE;" & @CRLF & _
"$dawn-hover: #4864CD;" & @CRLF & _
"$periwinkle: #A98FFF;" & @CRLF & _
"$pastel-purple: #B7A1FF;" & @CRLF & _
"$carolina-blue: #87A5FF;" & @CRLF & _
"$pastel-blue: #9DB5FE;" & @CRLF & _
"$pale-grey: #EEF1F4;" & @CRLF & _
"$warm-pink: #FF3D79;" & @CRLF & _
"$warm-pink-darker: #e6376e;" & @CRLF & _
"$warm-pink-darkest: #c22f5d;" & @CRLF & _
"$warm-pink-15: rgba(255, 61, 121, .15);" & @CRLF & _
"$pale-grey-two: #E8EBED;" & @CRLF & _
"$pale-grey-two-50: rgba(232, 235, 237, .5);" & @CRLF & _
"$pale-grey-two-30: rgba(232, 235, 237, .3);" & @CRLF & _
"$pale-grey-two-70: rgba(232, 235, 237, .7);" & @CRLF & _
"$pale-grey-two-20: rgba(232, 235, 237, .2);" & @CRLF & _
"$pale-grey-two-10: rgba(232, 235, 237, .1);" & @CRLF & _
"$pale-grey-three: #EAEFF4;" & @CRLF & _
"$charcoal-grey: #2B2F35;" & @CRLF & _
"$charcoal-grey-80: rgba(43, 47, 43, .8); // rgba(42, 47, 52, .8)" & @CRLF & _
"$charcoal-grey-90: rgba(43, 47, 43, .9); // rgba(43, 47, 52, .9)" & @CRLF & _
"$charocol-grey-30: rgba(43, 47, 53, .3);" & @CRLF & _
"$silver: #DCE0E4; // #CFD2D4 #C9D0D5" & @CRLF & _
"$silver-two: #D2DADF;" & @CRLF & _
"$silver-three: #C9D0D5;" & @CRLF & _
"$azure: #00A6FF;" & @CRLF & _
"$azure-two: #0095E4;" & @CRLF & _
"$azure-hover: #008AD4;" & @CRLF & _
"$watermelon: #FF4168;" & @CRLF & _
"$light-30: rgba(152, 166, 179, .3);" & @CRLF & _
"$light-70: rgba(152, 166, 179, .7);" & @CRLF & _
"$cerulean: #007DC0;" & @CRLF & _
"$wheat: #FFD37E;" & @CRLF & _
"$off-white-two: #FFF6E1;" & @CRLF & _
"$pale-peach-two: #FFDEAD;" & @CRLF & _
"$ice-blue: #ECF9FF;" & @CRLF & _
"$pale-sky-blue: #B7E7FF;" & @CRLF & _
"$slate: #516272;" & @CRLF & _
"$bluey-grey: #97A6B2;" & @CRLF & _
"$bluey-grey-two: #98A7B3;" & @CRLF & _
"$bluey-grey-three: #A7B6C2;" & @CRLF & _
"$slate-three: #405064;" & @CRLF & _
"$slate-two: #404F5F;" & @CRLF & _
"$silver-four: #DEE1E4;" & @CRLF & _
"$silver-five: #D9DCDF;" & @CRLF & _
"$coral-pink: #FF5771;" & @CRLF & _
"$silver-six: #C0C9D0;" & @CRLF & _
"$sky-blue: #5CC7FF;" & @CRLF & _
"" & @CRLF & _
":export {" & @CRLF & _
" dark: $dark;" & @CRLF & _
" dark10: $dark-10;" & @CRLF & _
" dark20: $dark-20;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// not registered in zeplin" & @CRLF & _
"$warm-dark: #404F5F; // #435262" & @CRLF & _
"$warm-dark-40: rgba(64, 79, 95, .4); // rgba(64, 80, 101, .4)" & @CRLF & _
"$soft-sky: #8FD8FF;" & @CRLF & _
"$charcoal-grey-two: #2F343A;" & @CRLF & _
"$azure-three: #00C3FF;" & @CRLF & _
"$deep-green: #00A02E;" & @CRLF & _
"$sun-yellow: #F5E11F;" & @CRLF & _
"$cadet-blue: #52689D;" & @CRLF & _
"$greenblue: #00D175;" & @CRLF & _
"$greenblue-two: #00B07F;" & @CRLF & _
"$light-sky-blue: #CCF3FF;" & @CRLF & _
"$event-header: #EDEFF0;" & @CRLF & _
"" & @CRLF & _
"// react table" & @CRLF & _
"$tr-group-border: rgba(0, 0, 0, .05);" & @CRLF & _
"" & @CRLF & _
"// shop AB funnel page" & @CRLF & _
"$resource-a: #7ab8fc;" & @CRLF & _
"$resource-b: #86919f;" & @CRLF & _
"" & @CRLF & _
":export {" & @CRLF & _
" resourceA: $resource-a;" & @CRLF & _
" resourceB: $resource-b;" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")