$re = '/[0-9]+.[0-9]{2}/i';
$str = '$567.99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);