$re = '~(?P<leading> (?<=^/) /+ (?# Matches extra slashes after the first one) )
|
(?P<middle> (?<!^) (?<=/) /+ (?!$) (?# Matches extra slashes in the middle of the path) )
|
(?P<trailing> (?<!^) /+ (?=$) (?# Matches all trailing slashes) )~mxX';
$str = '== Description ==
match all extraneous (repeating) slashes from a path.
Also remove trailing slashes.
Keep one trailing slash if it\'s the string contains only slashes.
== Should not match ==
/some/dir
/some/dir
/
== Should match ==
/some/dir/
some/dir//
some/dir///
//some//dir//
//some///dir/
///very///wrong//////path//with///many/extra////slashes/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);