package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^\^_+"]+)"`)
var str = `"Q%LCJ8^1"+"Q%VOD.L"+"Q%LSEG.L[EQ_LIST]MID_PRICE"+"BRT-"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}