const regex = /123123\n[^\d]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('123123\\n[^\\d]+', 'g')
const str = `123123
some text
546454
some text
354543
some text
465466
some text
123123
some text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}