$re = '/(\w+(?: \w+)?) *\/ *(\w+"?(?: \w+)?)/m';
$str = 'MEDIUM /REGULAR INSEAM
XX LARGE /SHORT INSEAM
SMALL /32" INSM
X LARGE /30" INSM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);