$re = '/^(?!(?:.*?file){2}).*?file.*$/m';
$str = '123file345
asdffile12
file12file';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);