re = /^(?!.*\.txt).+$/m
str = 'happiness.html
joy.png
madness.html.txt
excitement.txt
fear.src'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end