package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{No}`)
var str = `The numbers are ⁰ ¹ ² ³ ⁴ ⁵ ⁶ ⁷ ⁸ ⁹ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}