$re = '/^(.+)\s+-\s+(.+?)\s*(?:\(([^()]+)\))?$/m';
$str = 'BLABLABLABLABLABLA BLABLABLA - BLABLA BLABLA (BLABLA1 BLABLA2)
BLABLABLABLABLABLA BLABLABLA - BLABLA BLABLA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);