package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^t]{2}st$`)
var str = `TTst
test
testt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}