$re = '/^\d(?:[()\s#-]*\d){4,}$/m';
$str = '1-2-3-4-5
123 45
2(134) 5
#123 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);