package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+[\+\-\*\/]{1})+\d+$`)
var str = `5+6+9
4*9+7-8
45++6*6
12+4+
+2-6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}