re = /abcdefgh/
str = 'sgsdgsdabcdefghhhrtyrswrtyjghmvnffvhsdfytdfdabcdefghjgjfdjhgghjgjgfh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end