$re = '/([|–] )\[([^]]+)\]( ?)/';
$str = '*Intro*
| [C] – [G] – [Am] – [F] – [Dm] – [G]
*VERSE 1*
=[C][G][Am]
=cu{a}nto he esp{e}rado este mo{m}ento
| [F] – [F] – [Dm] – [F] – [Dm] – [G]';
$subst = "$1<span class=\"chord\" data-original-title=\"$2\" title=\"$2\">$2</span>$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;