re = /^((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3})$|^((([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9\-]*[a-zA-Z0-9])\.)*([A-Za-z0-9]|[A-Za-z0-9][A-Za-z0-9\-]*[A-Za-z0-9]))$/m
str = 'host
host.dev
h.e.com
.dev
de.
1
1.
1.2
1.2.3
1.2.3.4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end