#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.+):(\d+):\s*(syntax\serror,\s)?(.+)"
Local $sString = "C:/Users/Landon/Desktop/bad.rb:2: syntax error, unexpected =>, expecting '}'" & @CRLF & _
" 'key' => 'value'," & @CRLF & _
" ^" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:2: syntax error, unexpected ',', expecting '}'" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: syntax error, unexpected =>, expecting '}'" & @CRLF & _
" 'other key' => 'value missing closing tick" & @CRLF & _
" ^" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: unterminated string meets end of file" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: can't find string "asdf" anywhere before EOF" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: unknown regexp optionwxyz - asdf" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: invalid multibyte char (asdf)" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: unterminated regexp meets end of file" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: unterminated here document identifier" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: incomplete character syntax" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: unterminated quoted string meets end of file" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: `$' without identifiers is not allowed as a global variable name" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: `$asdf' is not allowed as a global variable name" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: `@' without identifiers is not allowed as an instance variable name" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: `@@' without identifiers is not allowed as a class variable name" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: `@asdf' is not allowed as an instance variable name" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: `@@asdf' is not allowed as a class variable name" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: embedded document meets end of file" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: Invalid char `\\x%02X' in expression" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: string literal encodings differ (asdf / wxyz)" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: identifier %"PRIsVALUE" is not valid to get" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: identifier asdf is not valid to get" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: identifier %"PRIsVALUE" is not valid to set" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: invalid local variable - asdf" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: both block arg and actual block given" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: Can't set variable $asfd" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: block argument should not be given" & @CRLF & _
"C:/Users/Landon/Desktop/bad.rb:3: regexp encoding option 'asdf' differs from source encoding 'wxyz'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")