import re
regex = re.compile(r"<img.*?src=\"([^\"]*)\"[^>]*>(?:</img>)?", flags=re.IGNORECASE)
test_str = ("<b>More</b> <strike>formatting</strike> and stuff<br><br><p class=\"image-placeholder\"><img src=\"http://test.com/image1.gif\" alt=\"\" class=\"\" style=\"width: 100%\" title=\"\">Text <b>after</b> image<i></i></p> src is cool\n\n"
"<img alt=\"\" class=\"\" src=\"http://test.com/image2.gif\" style=\"width: 100%\" title=\"\"></img>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")