$re = '/(Quantity.*)(\d{1,})/';
$str = 'Quantity:12.23';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);