$re = '/^(?:(?>([a-f0-9]{1,4})(?>:(?1)){7}|(?!(?:.*[a-f0-9](?>:|$)){8,})((?1)(?>:(?1)){0,6})?::(?2)?)|(?>(?>(?1)(?>:(?1)){5}:|(?!(?:.*[a-f0-9]:){6,})(?3)?::(?>((?1)(?>:(?1)){0,4}):)?)?(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]?[0-9])(?>\.(?4)){3}))$/imD';
$str = '/*These should be valid*/
{Initial address}
2001:0db8:0000:0000:0000:ff00:0042:8329
{After removing all leading zeroes}
2001:db8:0:0:0:ff00:42:8329
{After omitting consecutive sections of zeroes}
2001:db8::ff00:42:8329
{The loopback address}
0000:0000:0000:0000:0000:0000:0000:0001
{The loopback address be abbreviated to ::1 by using both rules}
::1
{4 other valid test cases}
::FFFF:129.144.52.38
::129.144.52.38
::FFFF:d
1080:0:0:0:8:800:200C:417A
/*These 4 should be invalid*/
::FFFF:d.d.d
::FFFF:d.d
::d.d.d
::d.d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);