const regex = new RegExp('(to|from)=?<([a-zA-Z0-9_.-]+)\\@([A-Za-z_-]+)\\.(([A-Za-z]{3})|([A-Za-z]{3})\\.([A-Za-z]{2}?))>', 'gm')
const str = `Aug 26 07:07:07 napgwmail01 postfix/smtp[3723]: AA557C4225D: to=<lg.gagliardi@artilheiro.ig.com.br>, relay=none, delay=71932, delays=71931/0.12/0.01/0, dsn=4.4.1, status=deferred (connect to artilheiro.ig.com.br[200.226.134.74]:25: No route to host)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3706]: connect to smtp-gw.gentebanco.com.br[200.201.194.146]:25: No route to host
Aug 26 07:07:07 napgwmail01 postfix/smtp[3706]: EFA05C4257E: to=<fptorres@gentebanco.com.br>, relay=none, delay=71851, delays=71851/0.08/0.12/0, dsn=4.4.1, status=deferred (connect to smtp-gw.gentebanco.com.br[200.201.194.146]:25: No route to host)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3707]: connect to dagil.com.br[208.97.187.158]:25: Connection refused
Aug 26 07:07:07 napgwmail01 postfix/smtp[3707]: 0F48EC427F9: to=<vendasjba@dagil.com.br>, relay=none, delay=71825, delays=71825/0.08/0.21/0, dsn=4.4.1, status=deferred (connect to dagil.com.br[208.97.187.158]:25: Connection refused)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3712]: F2BB4C421AF: host mx.b.locaweb.com.br[187.45.217.20] said: 454 4.7.1 <claubertferreira@greencambioeturismo.com.br>: Relay access denied (in reply to RCPT TO command)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3737]: 7B5C9C42807: to=<martinsrd@ymail.com.br>, relay=ymail.com.br[69.162.74.2]:25, delay=71766, delays=71766/0.15/0.33/0, dsn=4.4.2, status=deferred (lost connection with ymail.com.br[69.162.74.2] while receiving the initial server greeting)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3688]: connect to mx.pop.com.br[200.175.8.224]:25: Connection refused
Aug 26 07:07:07 napgwmail01 postfix/smtp[3688]: 42B86C42354: to=<michelledocinho@pop.com.br>, relay=none, delay=59288, delays=59288/0.01/0.53/0, dsn=4.4.1, status=deferred (connect to mx.pop.com.br[200.175.8.224]:25: Connection refused)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3713]: F2BB4C421AF: to=<atendimento@rnviagens.com.br>, relay=none, delay=63394, delays=63393/0.1/0.45/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=rnviagens.com.br type=MX: Host not found, try again)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3728]: connect to gamail.com[75.126.104.242]:25: Connection refused
Aug 26 07:07:07 napgwmail01 postfix/smtp[3728]: DE280C421A2: to=<wdl.lourenco@gamail.com>, relay=none, delay=63395, delays=63394/0.13/0.45/0, dsn=4.4.1, status=deferred (connect to gamail.com[75.126.104.242]:25: Connection refused)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3734]: connect to netps.com[174.137.132.100]:25: Connection refused
Aug 26 07:07:07 napgwmail01 postfix/smtp[3734]: 3830BC427DD: to=<malagutti@netps.com>, relay=none, delay=71875, delays=71874/0.15/0.53/0, dsn=4.4.1, status=deferred (connect to netps.com[174.137.132.100]:25: Connection refused)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3704]: A9599C4285B: to<marcelo@bonstempos.com.br>, relay=mx.bonstempos.com.br[200.234.222.116]:25, delay=55068, delays=55067/0.13/0.58/0.05, dsn=4.7.1, status=deferred (host mx.bonstempos.com.br[200.234.222.116] said: 454 4.7.1 <marcelo@bonstempos.com.br>: Relay access denied (in reply to RCPT TO command))
Aug 26 07:07:07 napgwmail01 postfix/smtp[3722]: 6BF30C42750: host mx.a.locaweb.com.br[186.202.4.42] said: 454 4.7.1 <camila@cafeteriafinograo.com.br>: Relay access denied (in reply to RCPT TO command)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3725]: AE29AC4202E: host mx01.mx-server.net[186.202.4.42] said: 454 4.7.1 <barbara.paiva@brmall.com.br>: Relay access denied (in reply to RCPT TO command)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3711]: F2BB4C421AF: host mx.a.locaweb.com.br[186.202.4.42] said: 454 4.7.1 <kaique@cgt.tur.br>: Relay access denied (in reply to RCPT TO command)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3712]: F2BB4C421AF: to=<claubertferreira@greencambioeturismo.com.br>, relay=mx.a.locaweb.com.br[186.202.4.42]:25, delay=63394, delays=63393/0.1/0.37/0.32, dsn=4.7.1, status=deferred (host mx.a.locaweb.com.br[186.202.4.42] said: 454 4.7.1 <claubertferreira@greencambioeturismo.com.br>: Relay access denied (in reply to RCPT TO command))
Aug 26 07:07:07 napgwmail01 postfix/smtp[3722]: 6BF30C42750: to=<camila@cafeteriafinograo.com.br>, relay=mx.b.locaweb.com.br[187.45.217.20]:25, delay=71930, delays=71930/0.13/0.66/0.01, dsn=4.7.1, status=deferred (host mx.b.locaweb.com.br[187.45.217.20] said: 454 4.7.1 <camila@cafeteriafinograo.com.br>: Relay access denied (in reply to RCPT TO command))
Aug 26 07:07:07 napgwmail01 postfix/smtp[3711]: F2BB4C421AF: to=<kaique@cgt.tur.br>, relay=mx.b.locaweb.com.br[187.45.217.20]:25, delay=63394, delays=63393/0.1/0.71/0.01, dsn=4.7.1, status=deferred (host mx.b.locaweb.com.br[187.45.217.20] said: 454 4.7.1 <kaique@cgt.tur.br>: Relay access denied (in reply to RCPT TO command))
Aug 26 07:07:07 napgwmail01 postfix/smtp[3725]: AE29AC4202E: to=<barbara.paiva@brmall.com.br>, relay=mx02.mx-server.net[186.202.4.42]:25, delay=29942, delays=29941/0.13/0.65/0.01, dsn=4.7.1, status=deferred (host mx02.mx-server.net[186.202.4.42] said: 454 4.7.1 <barbara.paiva@brmall.com.br>: Relay access denied (in reply to RCPT TO command))
Aug 26 07:07:07 napgwmail01 postfix/smtp[3687]: 44BE0C418FF: host srv1.westtournatal.com.br[191.101.225.253] said: 450 4.1.1 <reservas@westtournatal.com.br>: Recipient address rejected: User unknown in virtual mailbox table (in reply to RCPT TO command)
Aug 26 07:07:07 napgwmail01 postfix/smtp[3705]: connect to email.motorola.com[144.189.100.66]:25: Connection refused
Aug 26 07:07:07 napgwmail01 postfix/smtp[3705]: EFA05C4257E: to=<alb032@email.motorola.com>, relay=none, delay=71852, delays=71851/0.08/0.84/0, dsn=4.4.1, status=deferred (connect to email.motorola.com[144.189.100.66]:25: Connection refused)
Aug 26 07:07:08 napgwmail01 postfix/smtp[3716]: BFC0EC420FC: host aspmx.l.google.com[64.233.186.27] said: 452-4.2.2 The email account that you tried to reach is over quota. Please direct 452-4.2.2 the recipient to 452 4.2.2 https://support.google.com/mail/answer/6558 j185si13676489qkd.130 - gsmtp (in reply to RCPT TO command)
Aug 26 07:07:08 napgwmail01 postfix/smtp[3732]: 14C3DC421CC: to=<julianarubia@oi.com.br>, relay=mx7.oi.com.br[177.154.139.187]:25, delay=63311, delays=63310/0.14/1/0.01, dsn=4.2.1, status=deferred (host mx7.oi.com.br[177.154.139.187] said: 451 4.2.1 mailbox temporarily disabled: julianarubia@oi.com.br (in reply to RCPT TO command))
Aug 26 07:07:08 napgwmail01 postfix/smtp[3698]: CF572C42177: to=<julianarubia@oi.com.br>, relay=mx7.oi.com.br[177.154.139.187]:25, delay=63434, delays=63433/0.05/1.2/0.01, dsn=4.2.1, status=deferred (host mx7.oi.com.br[177.154.139.187] said: 451 4.2.1 mailbox temporarily disabled: julianarubia@oi.com.br (in reply to RCPT TO command))
Aug 26 07:07:08 napgwmail01 postfix/smtp[3687]: 44BE0C418FF: to=<reservas@westtournatal.com.br>, relay=mail.westtournatal.com.br[191.101.225.253]:25, delay=44314, delays=44312/0.01/1.6/0.18, dsn=4.1.1, status=deferred (host mail.westtournatal.com.br[191.101.225.253] said: 450 4.1.1 <reservas@westtournatal.com.br>: Recipient address rejected: User unknown in virtual mailbox table (in reply to RCPT TO command))
Aug 26 07:07:08 napgwmail01 postfix/smtp[3719]: 6BCAEC4274F: to=<comercial03.joacaba@strasbourg.com.br>, relay=expresso.strasbourg.com.br[187.85.179.26]:25, delay=71931, delays=71930/0.12/1.2/0.49, dsn=4.1.1, status=deferred (host expresso.strasbourg.com.br[187.85.179.26] said: 450 4.1.1 <comercial03.joacaba@strasbourg.com.br>: Recipient address rejected: unverified address: host expresso.strasbourg.com.br[/var/run/cyrus/socket/lmtp] said: 550-Mailbox unknown. Either there is no mailbox associated with this 550-name or you do not have authorization to see it. 550 5.1.1 User unknown (in reply to RCPT TO command) (in reply to RCPT TO command))
Aug 26 07:07:09 napgwmail01 postfix/smtp[3697]: C1DE8C42746: to=<nely@dominusviagem.com.br>, relay=none, delay=71929, delays=71926/0.04/2.4/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=dominusviagem.com.br type=MX: Host not found, try again)
Aug 26 07:07:09 napgwmail01 postfix/smtp[3729]: 12E9EC41D6D: to=<l.amorim@l2tur.com.br>, relay=none, delay=63514, delays=63512/0.14/2.3/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=l2tur.com.br type=MX: Host not found, try again)
Aug 26 07:07:09 napgwmail01 postfix/smtp[3729]: 12E9EC41D6D: to=<lucas.meireles@l2tur.com.br>, relay=none, delay=63514, delays=63512/0.14/2.3/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=l2tur.com.br type=MX: Host not found, try again)
Aug 26 07:07:09 napgwmail01 postfix/smtp[3715]: B7EECC42122: to=<onlineturismo@onlineturismo-pe.com.br>, relay=none, delay=63467, delays=63464/0.11/2.4/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=onlineturismo-pe.com.br type=MX: Host not found, try again)
Aug 26 07:07:09 napgwmail01 postfix/smtp[3689]: 2772BC421A8: to=<regina@holandaturismo.com.br>, relay=none, delay=152817, delays=152814/0.08/2.8/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=holandaturismo.com.br type=MX: Host not found, try again)
Aug 26 07:07:09 napgwmail01 postfix/smtp[3716]: BFC0EC420FC: to=<manoellacampos@nordesteturismo.com.br>, relay=alt1.aspmx.l.google.com[74.125.140.27]:25, delay=63490, delays=63487/0.11/2.4/0.38, dsn=4.2.2, status=deferred (host alt1.aspmx.l.google.com[74.125.140.27] said: 452-4.2.2 The email account that you tried to reach is over quota. Please direct 452-4.2.2 the recipient to 452 4.2.2 https://support.google.com/mail/answer/6558 r7si18323224wjt.42 - gsmtp (in reply to RCPT TO command))
Aug 26 07:07:09 napgwmail01 postfix/smtp[3738]: 70B2BC42393: to=<luiz@terezacavalcanti.com.br>, relay=none, delay=59268, delays=59265/0.16/2.7/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=terezacavalcanti.com.br type=MX: Host not found, try again)
Aug 26 07:07:09 napgwmail01 postfix/smtpd[3247]: connect from unknown[172.16.21.131]
Aug 26 07:07:09 napgwmail01 postfix/smtpd[3247]: NOQUEUE: discard: RCPT from unknown[172.16.21.131]: <>: Sender address "BOUNCE DETECTED DISCARDING"; from=<> to=<noreply@voeazul.com.br> proto=ESMTP helo=<NAPHBEX01.intra.cvc>
Aug 26 07:07:09 napgwmail01 postfix/smtpd[3247]: F3B64C41A01: client=unknown[172.16.21.131]
Aug 26 07:07:10 napgwmail01 postfix/smtpd[3247]: disconnect from unknown[172.16.21.131]
Aug 26 07:07:12 napgwmail01 postfix/smtp[3723]: D74A0C41792: to=<Cristiane.ribeiro@arliquide.com>, relay=none, delay=59604, delays=59598/0.13/5.4/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=arliquide.com type=MX: Host not found, try again)
Aug 26 07:07:20 napgwmail01 postfix/smtpd[3247]: connect from unknown[172.16.21.131]
Aug 26 07:07:20 napgwmail01 postfix/smtpd[3247]: A04DFC41B25: client=unknown[172.16.21.131]
Aug 26 07:07:20 napgwmail01 postfix/cleanup[3683]: A04DFC41B25: message-id=<284FD6FDB08FF948ACA40EBBCB7B918A2003007D@NAPMAILEX02.intra.cvc>
Aug 26 07:07:20 napgwmail01 postfix/qmgr[30710]: A04DFC41B25: from=<suportera@cvc.com.br>, size=71325, nrcpt=1 (queue active)
Aug 26 07:07:20 napgwmail01 clamsmtpd: BEF8E5: accepted connection from: 127.0.0.1
Aug 26 07:07:20 napgwmail01 postfix/smtpd[3680]: connect from localhost[127.0.0.1]
Aug 26 07:07:20 napgwmail01 postfix/smtpd[3247]: disconnect from unknown[172.16.21.131]
Aug 26 07:07:20 napgwmail01 postfix/smtpd[3680]: AE38FC41B3F: client=localhost[127.0.0.1], orig_queue_id=A04DFC41B25, orig_client=unknown[172.16.21.131]
Aug 26 07:07:20 napgwmail01 postfix/cleanup[3034]: AE38FC41B3F: message-id=<284FD6FDB08FF948ACA40EBBCB7B918A2003007D@NAPMAILEX02.intra.cvc>
Aug 26 07:07:20 napgwmail01 postfix/smtp[3678]: A04DFC41B25: to=<atendimento.hoteis@rexturadvance.com.br>, relay=127.0.0.1[127.0.0.1]:10025, delay=0.16, delays=0.02/0/0.04/0.1, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as AE38FC41B3F)
Aug 26 07:07:20 napgwmail01 postfix/qmgr[30710]: AE38FC41B3F: from=<suportera@cvc.com.br>, size=71623, nrcpt=1 (queue active)
Aug 26 07:07:20 napgwmail01 clamsmtpd: BEF8E5: from=suportera@cvc.com.br, to=atendimento.hoteis@rexturadvance.com.br, status=CLEAN
Aug 26 07:07:20 napgwmail01 postfix/smtpd[3680]: disconnect from localhost[127.0.0.1]
Aug 26 07:07:20 napgwmail01 postfix/qmgr[30710]: A04DFC41B25: removed
Aug 26 07:07:22 napgwmail01 postfix/smtp[3707]: AE38FC41B3F: to=<atendimento.hoteis@rexturadvance.com.br>, relay=aspmx.l.google.com[64.233.186.27]:25, delay=2.2, delays=0.1/0/0.48/1.7, dsn=2.0.0, status=sent (250 2.0.0 OK 1472206042 49si13710001qtm.41 - gsmtp)
Aug 26 07:07:22 napgwmail01 postfix/qmgr[30710]: AE38FC41B3F: removed
Aug 26 07:07:23 napgwmail01 postfix/smtpd[3247]: connect from unknown[172.16.21.131]
Aug 26 07:07:23 napgwmail01 postfix/smtpd[3247]: NOQUEUE: discard: RCPT from unknown[172.16.21.131]: <>: Sender address "BOUNCE DETECTED DISCARDING"; from=<> to=<prvs=0397269d0=voegol@voegol.com.br> proto=ESMTP helo=<NAPHBEX01.intra.cvc>
Aug 26 07:07:23 napgwmail01 postfix/smtpd[3247]: C5C53C41B25: client=unknown[172.16.21.131]
Aug 26 07:07:23 napgwmail01 postfix/smtpd[3247]: disconnect from unknown[172.16.21.131]
Aug 26 07:07:24 napgwmail01 postfix/smtpd[3247]: connect from unknown[172.16.21.131]
Aug 26 07:07:24 napgwmail01 postfix/smtpd[3247]: NOQUEUE: discard: RCPT from unknown[172.16.21.131]: <>: Sender address "BOUNCE DETECTED DISCARDING"; from=<> to=<prvs=0397269d0=voegol@voegol.com.br> proto=ESMTP helo=<NAPHBEX01.intra.cvc>
Aug 26 07:07:24 napgwmail01 postfix/smtpd[3247]: DD7B1C41B25: client=unknown[172.16.21.131]
Aug 26 07:07:24 napgwmail01 postfix/smtpd[3247]: disconnect from unknown[172.16.21.131]
Aug 26 07:07:26 napgwmail01 postfix/smtpd[3247]: connect from unknown[172.16.21.131]
Aug 26 07:07:26 napgwmail01 postfix/smtpd[3247]: NOQUEUE: discard: RCPT from unknown[172.16.21.131]: <>: Sender address "BOUNCE DETECTED DISCARDING"; from=<> to=<prvs=0397269d0=voegol@voegol.com.br> proto=ESMTP helo=<NAPHBEX01.intra.cvc>
Aug 26 07:07:26 napgwmail01 postfix/smtpd[3247]: 074FBC41B25: client=unknown[172.16.21.131]
Aug 26 07:07:26 napgwmail01 postfix/smtpd[3247]: disconnect from unknown[172.16.21.131]
Aug 26 07:07:37 napgwmail01 postfix/smtp[3506]: connect to live.com.br[200.186.148.211]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3506]: 44BE0C418FF: to=<asasturismo@live.com.br>, relay=none, delay=44342, delays=44312/0/30/0, dsn=4.4.1, status=deferred (connect to live.com.br[200.186.148.211]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3690]: connect to lexxanet.com.br[177.71.193.51]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3690]: 40CB0C42F1D: to=<taiane.397@lexxanet.com.br>, relay=none, delay=78453, delays=78423/0.02/30/0, dsn=4.4.1, status=deferred (connect to lexxanet.com.br[177.71.193.51]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3693]: connect to lexxanet.com.br[177.71.193.51]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3693]: 9FAE2C424B2: to=<jbobsilva@lexxanet.com.br>, relay=none, delay=71907, delays=71877/0.03/30/0, dsn=4.4.1, status=deferred (connect to lexxanet.com.br[177.71.193.51]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3696]: connect to lexxanet.com.br[177.71.193.51]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3696]: 99A34C4231E: to=<global@lexxanet.com.br>, relay=none, delay=74071, delays=74041/0.04/30/0, dsn=4.4.1, status=deferred (connect to lexxanet.com.br[177.71.193.51]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3699]: connect to outook.com[69.162.80.55]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3699]: C4B38C421C4: to=<davidson.henrique@outook.com>, relay=none, delay=63340, delays=63310/0.05/30/0, dsn=4.4.1, status=deferred (connect to outook.com[69.162.80.55]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3703]: connect to destinocerto.tur.br[52.34.168.217]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3703]: 2772BC421A8: to=<atendimento@destinocerto.tur.br>, relay=none, delay=152844, delays=152814/0.07/30/0, dsn=4.4.1, status=deferred (connect to destinocerto.tur.br[52.34.168.217]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3714]: connect to monacoturismo.com.br[192.169.82.94]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3714]: B7EECC42122: to=<marcelowaked@monacoturismo.com.br>, relay=none, delay=63494, delays=63464/0.11/30/0, dsn=4.4.1, status=deferred (connect to monacoturismo.com.br[192.169.82.94]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3709]: connect to acengenharia.com[54.210.33.190]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3721]: connect to cegirasol.com.br[23.236.62.147]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3721]: 69349C42742: to=<secretaria@cegirasol.com.br>, relay=none, delay=71877, delays=71847/0.13/30/0, dsn=4.4.1, status=deferred (connect to cegirasol.com.br[23.236.62.147]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3717]: connect to gmail.com.br[216.58.202.37]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3700]: connect to gmail.com.br[216.58.202.37]:25: Connection timed out
Aug 26 07:07:37 napgwmail01 postfix/smtp[3717]: 67144C41A3E: to=<enedir@gmail.com.br>, relay=none, delay=65869, delays=65839/0.12/30/0, dsn=4.4.1, status=deferred (connect to gmail.com.br[216.58.202.37]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3700]: 267F3C4208A: to=<msvalvano2014@gmail.com.br>, relay=none, delay=38212, delays=38182/0.06/30/0, dsn=4.4.1, status=deferred (connect to gmail.com.br[216.58.202.37]:25: Connection timed out)
Aug 26 07:07:37 napgwmail01 postfix/smtp[3733]: connect to gmail.com.br[216.58.202.37]:25: Connection timed out
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}