const regex = /^([a-zäöüÄÖÜß\s\d.,-]+?)\s*([\d\s]+(?:\s?[-|+\/]\s?\d+)?\s*[a-z]?)?\s*(\d{5})\s*(.+)?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zäöüÄÖÜß\\s\\d.,-]+?)\\s*([\\d\\s]+(?:\\s?[-|+\\\/]\\s?\\d+)?\\s*[a-z]?)?\\s*(\\d{5})\\s*(.+)?$', 'gmi')
const str = `Gewerbegebiet Ziesegrund 17440 Hohendorf bei Wolgast
Sonnenwiechser Str. 42 1/2 83052 Bruckmühl, Mangfall
Am Hamberg 4/1 79400 Kandern
Brüggerfeld 14 + 20 29574 Ebstorf
Straße des 17. Juni 18+19 88485 Berlin
Hochstr. 19 88045 Friedrichshafen
Straße des 17. Juni 23-25 a 12345 Berlin-Mitte
Domerschulstrasse 234 34070 Verlin
ERDINGERSTR.32 84405 DORFEN
GRüNERSTR. 14 A 67061 LUDWIGSHAFEN
KÖNIGSWINTER STR. 120 53227 BONN
GRÜNER WEG 11A
ERDINGERSTR.32 2443 DORFEN
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}