use strict;
my $str = 'Gewerbegebiet Ziesegrund 17440 Hohendorf bei Wolgast
Sonnenwiechser Str. 42 1/2 83052 Bruckmühl, Mangfall
Am Hamberg 4/1 79400 Kandern
Brüggerfeld 14 + 20 29574 Ebstorf
Straße des 17. Juni 18+19 88485 Berlin
Hochstr. 19 88045 Friedrichshafen
Straße des 17. Juni 23-25 a 12345 Berlin-Mitte
Domerschulstrasse 234 34070 Verlin
ERDINGERSTR.32 84405 DORFEN
GRüNERSTR. 14 A 67061 LUDWIGSHAFEN
KÖNIGSWINTER STR. 120 53227 BONN
GRÜNER WEG 11A
ERDINGERSTR.32 2443 DORFEN
';
my $regex = qr/^(.*?)(?:\h+(\d+(?:\h*[-|+\/]\h*\d+)*\h*[a-z]?\b))?(?:\h+(\d{4,5})(?:\h+(.*))?)?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}