import re
regex = re.compile(r"((?<=]|\n|^)(.*)\[((?<=\[)[AD][0-9A-F]+:|(?<=\[)[SBHO])(.*)\])")
test_str = ("asdf[D4:123456789012]\n"
"-------------------------------------------------------------\n"
"GUIDE TO FORMATS (INCOMPLETE)\n"
"Adding functionality to the regex:\n"
">1----------<>2--|3---------------------||4-|2-<\n"
"((?<=]|\\n).*)(\\[((?<=\\[)[][]+:|(?<=\\[)[])(.*)\\])\n\n"
"1: catches a variable name by starting with a positive look behind of newline and ] and ^, followed by \"catch all until [\". so the regex will always match from the beginning of a variable. (not needed if testing for correct format, only included for this example.)\n"
"2: the data group. contains all the zesty regex.\n"
"3: regex to check for all the different types of data formats. The first checks for A and D, while the other checks for anything else. Notice the boolean OR \"|\". Note that it will match all of the string that it can. so more like \"as many as possible matches\"\n"
"4: just matches the actual data of the data group.\n"
"----------\n"
"var[<datatype> = type of data being stored followed by data. Ex:\n"
"var1[SSally sells sea shells by the sea shore]\n"
"----------\n"
"var[D<val>: = data stream followed by segment size followed by data. Ex: \n"
" >1-----<>2-----<>3-----<>4-----<\n"
"var1[D8:11111111000000001111111100000000]\n"
"-----------\n"
"var[A<val><pointers>: = array header followed by size of array followed by data, pointers inside array. (might not need size of array, since it wouldn't make anything more difficult to just make the array dynamic). Ex:\n"
"arr1[A4:2,5,1A,C3]\n"
"----------\n")
subst = "Var name+data group: $1 Data group: $2\\nData group type: $3 Data itself: $4"
result = regex.sub(subst, test_str)
if result:
print(result)