package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`function\s*([A-z0-9]+)?\s*\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)\s*\{(?:[^}{]+|\{(?:[^}{]+|\{[^}{]*\})*\})*\}`)
var str = `function example (a,b){ return 1 }
function (){
...
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}