re = /^[^v]+$|^v[^\d].+/m
str = 'v313.2014.toyota.camry.0.jpg
v313.2014.toyota.camry.1.jpg
fordfusion.jpg
fordfusion2.jpg
v87.2015.honda.civic.0.jpg
v87.2015.honda.civic.1.jpg
2014.ford.escape.0.jpg
2014.ford.escape.1.jpg
vehicle1.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end