$re = '/^[A-Z][a-z]{2}[0-9]{3}$/';
$str = 'Aab123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);