$re = '`(?:contact-us/support-for-client-administrators/glossary)(?:/)?(?:.*[^0-9a-zA-Z].*)?(?:\\\\.aspx)?$`mi';
$str = 'https://banana.com/contact-us/support-for-client-administrators/glossary/affordable-care-act.aspx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);