const regex = /<div class="col-md-3">\s*<div class="card text-center">[\s]*<img src="https:\/\/my\.dedino\.ir\/storage\/plans\/[\d]{3}\.jpg" width="200" height="200" class="card-img-top" alt="(?'MainerName'.*)">[\s]*<div class="card-body">[\s]*<h5 class="card-title">.*<\/h5>[\s]*<p class="card-text"><\/p>[\s]*<a href="https:\/\/my\.dedino\.ir\/panel\/cart\/preview\/[\d]{3}" class=".*">[\s]*<i class="fa fa-cart-plus"><\/i>\s*\W*<\/a>\s*<\/div>\s*<div class="card-footer text-muted text-center">\s*\W*<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="(?'Rial'[\d]{0,3}[,]{0,1}[\d]{0,3}[,]{0,1}[\d]{0,3}[,]{0,1}[\d]{0,3})\s*\W*"><u>(?'P'0.[0-9]{0,10})\s*BTC\/\s*month<\/u>\s*<\/strong>\s*<\/div>\s*<div class="card-footer text-muted text-center">\s*\W*<strong dir="ltr">(?'Cost'[0-9]{0,2})%<\/strong>\s*<\/div>\s*<div class="card-footer text-muted text-center">\s*\W*<strong dir="ltr">(?'Total'0.[0-9]{0,10})BTC\s*\/month\s*<\/strong>\s*<\/div>\s*<\/div>\s*<\/div>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="col-md-3">\\s*<div class="card text-center">[\\s]*<img src="https:\\\/\\\/my\\.dedino\\.ir\\\/storage\\\/plans\\\/[\\d]{3}\\.jpg" width="200" height="200" class="card-img-top" alt="(?\'MainerName\'.*)">[\\s]*<div class="card-body">[\\s]*<h5 class="card-title">.*<\\\/h5>[\\s]*<p class="card-text"><\\\/p>[\\s]*<a href="https:\\\/\\\/my\\.dedino\\.ir\\\/panel\\\/cart\\\/preview\\\/[\\d]{3}" class=".*">[\\s]*<i class="fa fa-cart-plus"><\\\/i>\\s*\\W*<\\\/a>\\s*<\\\/div>\\s*<div class="card-footer text-muted text-center">\\s*\\W*<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="(?\'Rial\'[\\d]{0,3}[,]{0,1}[\\d]{0,3}[,]{0,1}[\\d]{0,3}[,]{0,1}[\\d]{0,3})\\s*\\W*"><u>(?\'P\'0.[0-9]{0,10})\\s*BTC\\\/\\s*month<\\\/u>\\s*<\\\/strong>\\s*<\\\/div>\\s*<div class="card-footer text-muted text-center">\\s*\\W*<strong dir="ltr">(?\'Cost\'[0-9]{0,2})%<\\\/strong>\\s*<\\\/div>\\s*<div class="card-footer text-muted text-center">\\s*\\W*<strong dir="ltr">(?\'Total\'0.[0-9]{0,10})BTC\\s*\\\/month\\s*<\\\/strong>\\s*<\\\/div>\\s*<\\\/div>\\s*<\\\/div>', 'gm')
const str = `<div class="row">
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/103.jpg" width="200" height="200" class="card-img-top" alt="Aladdin Miner 16Th/s">
<div class="card-body">
<h5 class="card-title">Aladdin Miner 16Th/s</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/103" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="12,020,000 ریال"><u>0.00431235
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00270061BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/104.jpg" width="200" height="200" class="card-img-top" alt="Bitfily Snow Panther A1">
<div class="card-body">
<h5 class="card-title">Bitfily Snow Panther A1</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/104" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="36,781,000 ریال"><u>0.01319630
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00826418BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/105.jpg" width="200" height="200" class="card-img-top" alt="StrongU STU-U8">
<div class="card-body">
<h5 class="card-title">StrongU STU-U8</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/105" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="34,529,000 ریال"><u>0.01238832
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00775819BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/106.jpg" width="200" height="200" class="card-img-top" alt="Pantech WX6">
<div class="card-body">
<h5 class="card-title">Pantech WX6</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/106" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="25,521,000 ریال"><u>0.00915642
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00573421BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/107.jpg" width="200" height="200" class="card-img-top" alt="Pantech SX6">
<div class="card-body">
<h5 class="card-title">Pantech SX6</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/107" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="6,380,000 ریال"><u>0.00228895
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00143345BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/108.jpg" width="200" height="200" class="card-img-top" alt="MicroBT Whatsminer M3X">
<div class="card-body">
<h5 class="card-title">MicroBT Whatsminer M3X</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/108" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="9,383,000 ریال"><u>0.00336625
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00210811BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/109.jpg" width="200" height="200" class="card-img-top" alt="MicroBT Whatsminer M21S">
<div class="card-body">
<h5 class="card-title">MicroBT Whatsminer M21S</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/109" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="42,036,000 ریال"><u>0.01508157
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00944483BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/110.jpg" width="200" height="200" class="card-img-top" alt="Innosilicon T3 39T">
<div class="card-body">
<h5 class="card-title">Innosilicon T3 39T</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/110" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="29,275,000 ریال"><u>0.01050305
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00657753BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/111.jpg" width="200" height="200" class="card-img-top" alt="Innosilicon T2 Turbo 25T">
<div class="card-body">
<h5 class="card-title">Innosilicon T2 Turbo 25T</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/111" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="18,765,000 ریال"><u>0.00673250
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00421622BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/112.jpg" width="200" height="200" class="card-img-top" alt="Halong Mining DragonMint T1">
<div class="card-body">
<h5 class="card-title">Halong Mining DragonMint T1</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/112" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="12,011,000 ریال"><u>0.00430920
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00269864BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/113.jpg" width="200" height="200" class="card-img-top" alt="GMO miner B3">
<div class="card-body">
<h5 class="card-title">GMO miner B3</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/113" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="24,770,000 ریال"><u>0.00888710
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00556554BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/114.jpg" width="200" height="200" class="card-img-top" alt="GMO miner B2">
<div class="card-body">
<h5 class="card-title">GMO miner B2</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/114" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="18,014,000 ریال"><u>0.00646317
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00404756BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/115.jpg" width="200" height="200" class="card-img-top" alt="Bitmain Antminer S11 (20.5Th)">
<div class="card-body">
<h5 class="card-title">Bitmain Antminer S11 (20.5Th)</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/115" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="15,388,000 ریال"><u>0.00552085
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00345743BTC
/month
</strong>
</div>
</div>
</div>
<div class="col-md-3">
<div class="card text-center">
<img src="https://my.dedino.ir/storage/plans/116.jpg" width="200" height="200" class="card-img-top" alt="StrongU STU-U8 Pro">
<div class="card-body">
<h5 class="card-title">StrongU STU-U8 Pro</h5>
<p class="card-text"></p>
<a href="https://my.dedino.ir/panel/cart/preview/116" class="btn btn-primary btn-block">
<i class="fa fa-cart-plus"></i>
افزودن به سبد خرید
</a>
</div>
<div class="card-footer text-muted text-center">
درآمد دوره:
<strong dir="ltr" data-toggle="tooltip" data-placement="top" title="34,529,000 ریال"><u>0.01238832
BTC/
month</u>
</strong>
</div>
<div class="card-footer text-muted text-center">
هزینه نگهداری:
<strong dir="ltr">25%</strong>
</div>
<div class="card-footer text-muted text-center">
مبلغ کل:
<strong dir="ltr">0.00775819BTC
/month
</strong>
</div>
</div>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}