$re = '/^[a-z0-9:_\/+-]+$/i';
$str = 'dfwetf3465d+';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);