package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{1,})`)
var str = `ax(341);ay(20);az(3131);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}