using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\u041C?\d+\u0445\d+";
string input = @"Screw М4х20 , DIN7985";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}