package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)users=(.*)&`)
var str = `mysite.com/page?users=all&page=2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}