const regex = /(?<method>(GET|POST))\s*(?<uri>[\S]+)\s*(?<protocol>(HTTP|\w+)\/[\S]+)\s*(.*?)(?<status>[\d]+)\s\d+\s*\d+\.\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<method>(GET|POST))\\s*(?<uri>[\\S]+)\\s*(?<protocol>(HTTP|\\w+)\\\/[\\S]+)\\s*(.*?)(?<status>[\\d]+)\\s\\d+\\s*\\d+\\.\\d+', 'g')
const str = `[2/Jun/2009:07:36:19 -0600] secure.com 196.49.49.36 196.49.49.36 10.19.48.71, 57.28.75.174 57.28.75.196 GET /api-dual/us HTTP/1.1 200 2013 0.764 https://secure.chas.com/ no-cache, max-age=0 Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 Chrome/55.0.2883.8537 Safari/7.310.4031EB0C1D8BE068A9BD600440A5D792 jcXr-RtOQKZS804wxfPLCFZ3 - Web
[2/Jun/2009:07:36:19 -0600] api.co.us 196.49.49.36 196.49.49.36 10.19.48.71 - POST /api-dual/menu/Identity HTTP/1.1 200 47 0.659 - no-cache Apache CXF 3.1.0 - - - -
[2/Jun/2009:07:36:19 -0600] 196.49.49.47 196.49.49.47 - GET /api-login/ HTTP/1.1 200 163 0.002 - - - - - - -
[[2/Jun/2009:07:36:19 -0600] secure.com 196.49.49.47 196.49.49.47 10.19.48.71, 57.28.75.174 57.28.75.196 GET /api-dual/accounts/?status=Posted&toDate=2009-06-02&fromDate=2009-06-24&channelType=Mobile&action=next HTTP/1.1 ?status=Posted&toDate=2009-06-24&fromDate=2016-09-24&channelType=Mobile&action=next 200 13898 0.194 https://secure.com max-age=0 Mozilla/5.0 (iPhone; CPU iPhone OS 9_3_5 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Mobile/13G36 F72AEE043E08F5020E2F5A84F58774EE zKplRZORI+gYDxth6rxIj8rZ -chs26`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}