$re = '/^(1[0-2]|0?[1-9]):[0-5][0-9] (AM|PM)$/i';
$str = '01:05 PM';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);