using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#?([a-f\d])([a-f\d])([a-f\d])$";
string input = @"##ddd";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}