$re = '/^(.*?)(H{1,2})((.*?)(M{1,2})((.*?)(S{1,2})(.*?)|.*)|.*)$/m';
$str = 'H:M:Ss
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);