package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(0?[1-9]|1[0-9]|2[0-5])\b`)
var str = `1 00 0 12 10 23 24 25 26`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}