$re = '/first.*second/s';
$str = 'fddfgdfgfdg phrase here first
sdafdsafdsa
sadfsadf
sadfdsaf
phrase here second
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);