$re = '/(\d+)|(\D)/';
$str = 'CC
5
B7C15
B4C8
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);